Hack x Crack - Comunidad de Seguridad informática

Seguridad Informatica => Hacking => Hacking Wireless => Mensaje iniciado por: RoamingSK en Agosto 26, 2015, 05:16:54 am

Título: No me funciona modo monitor
Publicado por: RoamingSK en Agosto 26, 2015, 05:16:54 am
holas,alguien con experiencia me podria ayudar,ya que he buscado y buscado y no puedo entender, el problema es que no me anda el modo monitor, y sospecho de que sea mi tarjeta LAN inalámbrica 802.11n USB (adaptador de red=Ralink Technology, Corp.es ), en kalilinux he probado de cambiar mi ip y tampoco me aparece the primary newtork interface,alguien sabria algo?
Título: Re:No me funciona modo monitor
Publicado por: ak3tres en Agosto 26, 2015, 05:57:20 am
Buenas RoamingSK Primero que nada consultarte si es que kali Linux lo estas ejecutando en una maquina virtual o instalado en un disco duro.
Al estar en un maquina virtual esta no tiene las caracteristicas para usar tu tarjeta de red integrada en tu pc a lo que deverias de comprar una usb que soporte inyeccion de paquetes y que se pueda poner en modo monitor lo otro si es que tienes kali Linux como So primario por asi decirlo entra en la consola y con permisos de administrador tipea el siguiente comando

sudo ifconfig

y pega en este hilo lo que te devuelve para que nosotros podamos tener mas informacion  C:

Ojala te alla servido la ayuda
Título: Re:No me funciona modo monitor
Publicado por: RoamingSK en Agosto 26, 2015, 04:01:42 pm
Lo que yo tengo es kalilinux montado en una maquina virtual con vmware,y en realidad no tengo tarjeta de red integrada al la pc, lo único que tengo es ese usb(una antena)que me conecta a las redes wifi.
Título: Re:No me funciona modo monitor
Publicado por: salemalaga30 en Agosto 26, 2015, 04:37:27 pm
As probado a montar la tarjeta en vmware primero para que te la reconozca el sistema.
Título: Re:No me funciona modo monitor
Publicado por: ak3tres en Agosto 27, 2015, 03:58:36 am
Como muy bien dice salemalaga en las configuraciones de hadware de tu maquina virtual en este caso kali Linux en la parte de usb te deveria decir si quieres agregar la tarjeta usb de wifi si no es el caso que te salga listada hay puede ser que necesites instalar los drivers de dicha tarjeta en tu pc anfitrion pero al parecer tu ya la ocupabas y por lo tanto deben estar instalados cuando le des a iniciar a la maquina virtual de Kali Linux pon atencion en la parte inferior derecha de la pantalla donde se esta cargando tu maquina y veras varios iconos uno de ellos es para dar de alta tu tarjeta usb de wifi y entonces la detectara el kernel y estara lista en tu distro para que luego veas si es que esta disponible le haces en la shell de linux el iwconfig y deveria salirte la tarjeta como algun tipo de Wlan0 u otro Saludos
Título: Re:No me funciona modo monitor
Publicado por: RoamingSK en Agosto 27, 2015, 06:20:47 pm
el problema es que cuando activo el modo promiscuo de la tarjeta  con airmon-ng start wlan0 en la terminal me aparece
found 5 process, he visto videos y normalmente aparecen 2 pero no se si tiene que ver,y luego me aparece:
PHY   Interface      Driver                Chipset
phy 3  wlan0       rt2800usb         ralink technology  rt2870/rt3070
                                                  (mac80211 monitor mode vif enable for [phy3]wlan0 on [phy3]wlan0mon)
                                                   (mac80211 station mode vif disabled  for [phy3]wlan0)
y cuando pongo iwconfig me aparece:

eth0      no wireless extensions.

wlan0mon  IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
lo        no wireless extensions.

Y aca lo final: airodump-ng wlan0mon

ioctl(SIOCSIWMODE) failed: Device or resource busy
ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make
sure RFMON is enabled: run 'airmon-ng start wlan0mon <#>'
Sysfs injection support was not found either.
y ahi me stanko,no se si se entiende...


Título: Re:No me funciona modo monitor
Publicado por: obiWan_K en Abril 02, 2020, 09:00:58 am
tienes que matar los procesos primero con

airmon-ng check kill

y ya continuas