Hack x Crack - Comunidad de Seguridad informática

Sistemas operativos => GNU / Linux => Mensaje iniciado por: Blest777 en Marzo 03, 2016, 08:38:56 am

Título: No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: Blest777 en Marzo 03, 2016, 08:38:56 am
Hola. Estoy tratando de instalar este programa en Ubuntu:
 
Código: [Seleccionar]
$ git clone https://github.com/P0cL4bs/3vilTwinAttacker.git
$ cd 3vilTwinAttacker
$ sudo chmod +x installer.sh
$ sudo ./installer.sh --install
 
Se instala todo bien, pero cuando quiero ejecutarlo para abrirlo con:

 
Código: [Seleccionar]
python 3vilTwinAttacker.py
Me tira el siguiente error:

 
Código: [Seleccionar]
[email protected]:~/3vilTwinAttacker$ python 3vilTwinAttacker.py
python: can't open file '3vilTwinAttacker.py': [Errno 2] No such file or directory

Que estoy haciendo mal? como puedo solucionar esto?

Gracias de antemano


Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: b10s_0v3rr1d3 en Marzo 03, 2016, 01:43:27 pm
hi,

te tira directamente error en el file que estas intentando usar, si el file esta marcado con el perm para ejecucion no te hace falta el 'python' de delante
Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: Blest777 en Marzo 03, 2016, 08:16:03 pm
Gracias por tu respuesta

Cuando le quito python al comando y ejecuto me tira:
 
Código: [Seleccionar]
[email protected]:/home/blest# cd 3vilTwinAttacker
[email protected]:/home/blest/3vilTwinAttacker# 3vilTwinAttacker.py
3vilTwinAttacker.py: command not found

Tanbien trate de esta forma:

 
Código: [Seleccionar]
[email protected]:~# cd 3vilTwinAttacker
[email protected]:~/3vilTwinAttacker# ls
CHANGELOG        Icons         Logs     Proxy             Settings
CONTRIBUTING.md  installer.sh  Modules  README.md         Templates
Core             LICENSE       Plugins  requirements.txt  wifi-pumpkin.py
[email protected]:~/3vilTwinAttacker# chmod +x wifi-pumpkin.py
[email protected]:~/3vilTwinAttacker# python wifi-pumpkin.py
Traceback (most recent call last):
  File "wifi-pumpkin.py", line 5, in <module>
    from Core.Main import Initialize
  File "/root/3vilTwinAttacker/Core/Main.py", line 3, in <module>
    from Proxy import *
  File "/root/3vilTwinAttacker/Proxy/htmlinjector.py", line 1, in <module>
    from Plugin import PluginProxy
  File "/root/3vilTwinAttacker/Proxy/Plugin.py", line 2, in <module>
    from Core.Utils import setup_logger
  File "/root/3vilTwinAttacker/Core/Utils.py", line 8, in <module>
    from BeautifulSoup import BeautifulSoup
ImportError: No module named BeautifulSoup


Como solucionar ese problema?
Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: howara en Marzo 03, 2016, 08:55:56 pm
Prueba primero... :
Código: Bash
  1. sudo apt-get install python-beautifulsoup
  2.  
Si no va, mira esto -> http://stackoverflow.com/questions/28397879/no-module-named-beautifulsoup

Suerte!
Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: Blest777 en Marzo 04, 2016, 12:36:59 am
 
Código: [Seleccionar]
[email protected]:/home/blest# sudo apt-get install python-beautifulsoup
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  python-beautifulsoup
0 upgraded, 1 newly installed, 0 to remove and 168 not upgraded.
Need to get 34.6 kB of archives.
After this operation, 164 kB of additional disk space will be used.
Get:1 http://ci.archive.ubuntu.com/ubuntu/ wily/universe python-beautifulsoup all 3.2.1-1 [34.6 kB]
Fetched 34.6 kB in 0s (35.7 kB/s)             
Selecting previously unselected package python-beautifulsoup.
(Reading database ... 184373 files and directories currently installed.)
Preparing to unpack .../python-beautifulsoup_3.2.1-1_all.deb ...
Unpacking python-beautifulsoup (3.2.1-1) ...
Setting up python-beautifulsoup (3.2.1-1) ...

[email protected]:/home/blest# cd 3vilTwinAttacker

[email protected]:/home/blest/3vilTwinAttacker# ls
CHANGELOG        Icons         Logs     Proxy             Settings
CONTRIBUTING.md  installer.sh  Modules  README.md         Templates
Core             LICENSE       Plugins  requirements.txt  wifi-pumpkin.py

[email protected]:/home/blest/3vilTwinAttacker# python wifi-pumpkin.py
Traceback (most recent call last):
  File "wifi-pumpkin.py", line 5, in <module>
    from Core.Main import Initialize
  File "/home/blest/3vilTwinAttacker/Core/Main.py", line 3, in <module>
    from Proxy import *
  File "/home/blest/3vilTwinAttacker/Proxy/htmlinjector.py", line 1, in <module>
    from Plugin import PluginProxy
  File "/home/blest/3vilTwinAttacker/Proxy/Plugin.py", line 2, in <module>
    from Core.Utils import setup_logger
  File "/home/blest/3vilTwinAttacker/Core/Utils.py", line 9, in <module>
    from netaddr import EUI
ImportError: No module named netaddr

[email protected]:/home/blest/3vilTwinAttacker# wifi-pumpkin.py
wifi-pumpkin.py: command not found

Tambien noto este error en rojo:

(http://s11.postimg.org/ht5t85xmr/Screenshot_from_2016_03_04_02_02_27.png)

Me sigue tirando los errrores? sera que me faltan dependecias para instalar ese programa?
Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: howara en Marzo 04, 2016, 11:20:55 am
Mira qué versión de python usa ese programa y comprueba que el python que ejecutas es el adecuado. Si sigue fallando ves instalando las dependencias que te vaya diciendo el programa.

P.D: Usa google. Casi todo lo que has hecho era coger el error, ponerlo en google y mirar el primer enlace a stackoverflow.

Suerte.
Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: b10s_0v3rr1d3 en Marzo 04, 2016, 04:57:13 pm
@Blest777, fijate que en la wiki del proyecto te comenta justamente las dependencias que tiene y detalles: https://github.com/P0cL4bs/WiFi-Pumpkin/wiki/Installation

luego tienes tambien otro file con los requisitos: https://github.com/P0cL4bs/WiFi-Pumpkin/blob/master/requirements.txt

nos leemos ;)
Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: Blest777 en Marzo 04, 2016, 06:43:01 pm
Muchisimas gracias, lo pude instalar. El problema era con python. Ahora hay otro problema, no se conecta el Fake AP desde mi celular, dice:

Prueba01
Obtaining IP addresss...


(http://s9.postimg.org/8zi4inin3/Screenshot_from_2016_03_04_17_35_33.png)

 
Código: [Seleccionar]
[email protected]:~$  iw list
Wiphy phy1
max # scan SSIDs: 4
max scan IEs length: 2257 bytes
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Device supports RSN-IBSS.
Supported Ciphers:
* WEP40 (00-0f-ac:1)
* WEP104 (00-0f-ac:5)
* TKIP (00-0f-ac:2)
* CCMP (00-0f-ac:4)
* 00-0f-ac:10
* GCMP (00-0f-ac:8)
* 00-0f-ac:9
Available Antennas: TX 0 RX 0
Supported interface modes:
* IBSS
* managed
* AP
* AP/VLAN
* WDS
* monitor
* mesh point
Band 1:
Capabilities: 0x172
HT20/HT40
Static SM Power Save
RX Greenfield
RX HT20 SGI
RX HT40 SGI
RX STBC 1-stream
Max AMSDU length: 3839 bytes
No DSSS/CCK HT40
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 2 usec (0x04)
HT RX MCS rate indexes supported: 0-7, 32
TX unequal modulation not supported
HT TX Max spatial streams: 1
HT TX MCS rate indexes supported may differ
Bitrates (non-HT):
* 1.0 Mbps
* 2.0 Mbps (short preamble supported)
* 5.5 Mbps (short preamble supported)
* 11.0 Mbps (short preamble supported)
* 6.0 Mbps
* 9.0 Mbps
* 12.0 Mbps
* 18.0 Mbps
* 24.0 Mbps
* 36.0 Mbps
* 48.0 Mbps
* 54.0 Mbps
Frequencies:
* 2412 MHz [1] (30.0 dBm)
* 2417 MHz [2] (30.0 dBm)
* 2422 MHz [3] (30.0 dBm)
* 2427 MHz [4] (30.0 dBm)
* 2432 MHz [5] (30.0 dBm)
* 2437 MHz [6] (30.0 dBm)
* 2442 MHz [7] (30.0 dBm)
* 2447 MHz [8] (30.0 dBm)
* 2452 MHz [9] (30.0 dBm)
* 2457 MHz [10] (30.0 dBm)
* 2462 MHz [11] (30.0 dBm)
* 2467 MHz [12] (disabled)
* 2472 MHz [13] (disabled)
* 2484 MHz [14] (disabled)
Supported commands:
* new_interface
* set_interface
* new_key
* start_ap
* new_station
* new_mpath
* set_mesh_config
* set_bss
* authenticate
* associate
* deauthenticate
* disassociate
* join_ibss
* join_mesh
* set_tx_bitrate_mask
* frame
* frame_wait_cancel
* set_wiphy_netns
* set_channel
* set_wds_peer
* probe_client
* set_noack_map
* register_beacons
* start_p2p_device
* set_mcast_rate
* Unknown command (104)
* connect
* disconnect
Supported TX frame types:
* IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* P2P-device: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
Supported RX frame types:
* IBSS: 0x40 0xb0 0xc0 0xd0
* managed: 0x40 0xd0
* AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* mesh point: 0xb0 0xc0 0xd0
* P2P-client: 0x40 0xd0
* P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* P2P-device: 0x40 0xd0
software interface modes (can always be added):
* AP/VLAN
* monitor
valid interface combinations:
* #{ AP, mesh point } <= 8,
   total <= 8, #channels <= 1
HT Capability overrides:
* MCS: ff ff ff ff ff ff ff ff ff ff
* maximum A-MSDU length
* supported channel width
* short GI for 40 MHz
* max A-MPDU length exponent
* min MPDU start spacing
Device supports TX status socket option.
Device supports HT-IBSS.
Device supports SAE with AUTHENTICATE command
Device supports low priority scan.
Device supports scan flush.
Device supports AP scan.
Device supports per-vif TX power setting
Driver supports a userspace MPM
Wiphy phy0
max # scan SSIDs: 4
max scan IEs length: 2257 bytes
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Device supports RSN-IBSS.
Device supports AP-side u-APSD.
Device supports T-DLS.
Supported Ciphers:
* WEP40 (00-0f-ac:1)
* WEP104 (00-0f-ac:5)
* TKIP (00-0f-ac:2)
* CCMP (00-0f-ac:4)
* 00-0f-ac:10
* GCMP (00-0f-ac:8)
* 00-0f-ac:9
* CMAC (00-0f-ac:6)
* 00-0f-ac:13
* 00-0f-ac:11
* 00-0f-ac:12
Available Antennas: TX 0x1 RX 0x3
Configured Antennas: TX 0x1 RX 0x3
Supported interface modes:
* IBSS
* managed
* AP
* AP/VLAN
* WDS
* monitor
* mesh point
* P2P-client
* P2P-GO
Band 1:
Capabilities: 0x11ce
HT20/HT40
SM Power Save disabled
RX HT40 SGI
TX STBC
RX STBC 1-stream
Max AMSDU length: 3839 bytes
DSSS/CCK HT40
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 8 usec (0x06)
HT TX/RX MCS rate indexes supported: 0-7
Bitrates (non-HT):
* 1.0 Mbps
* 2.0 Mbps (short preamble supported)
* 5.5 Mbps (short preamble supported)
* 11.0 Mbps (short preamble supported)
* 6.0 Mbps
* 9.0 Mbps
* 12.0 Mbps
* 18.0 Mbps
* 24.0 Mbps
* 36.0 Mbps
* 48.0 Mbps
* 54.0 Mbps
Frequencies:
* 2412 MHz [1] (30.0 dBm)
* 2417 MHz [2] (30.0 dBm)
* 2422 MHz [3] (30.0 dBm)
* 2427 MHz [4] (30.0 dBm)
* 2432 MHz [5] (30.0 dBm)
* 2437 MHz [6] (30.0 dBm)
* 2442 MHz [7] (30.0 dBm)
* 2447 MHz [8] (30.0 dBm)
* 2452 MHz [9] (30.0 dBm)
* 2457 MHz [10] (30.0 dBm)
* 2462 MHz [11] (30.0 dBm)
* 2467 MHz [12] (disabled)
* 2472 MHz [13] (disabled)
* 2484 MHz [14] (disabled)
Supported commands:
* new_interface
* set_interface
* new_key
* start_ap
* new_station
* new_mpath
* set_mesh_config
* set_bss
* authenticate
* associate
* deauthenticate
* disassociate
* join_ibss
* join_mesh
* remain_on_channel
* set_tx_bitrate_mask
* frame
* frame_wait_cancel
* set_wiphy_netns
* set_channel
* set_wds_peer
* tdls_mgmt
* tdls_oper
* probe_client
* set_noack_map
* register_beacons
* start_p2p_device
* set_mcast_rate
* channel_switch
* Unknown command (104)
* connect
* disconnect
Supported TX frame types:
* IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* P2P-device: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
Supported RX frame types:
* IBSS: 0x40 0xb0 0xc0 0xd0
* managed: 0x40 0xd0
* AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* mesh point: 0xb0 0xc0 0xd0
* P2P-client: 0x40 0xd0
* P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* P2P-device: 0x40 0xd0
software interface modes (can always be added):
* AP/VLAN
* monitor
valid interface combinations:
* #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1,
   total <= 2048, #channels <= 1, STA/AP BI must match
* #{ WDS } <= 2048,
   total <= 2048, #channels <= 1, STA/AP BI must match
HT Capability overrides:
* MCS: ff ff ff ff ff ff ff ff ff ff
* maximum A-MSDU length
* supported channel width
* short GI for 40 MHz
* max A-MPDU length exponent
* min MPDU start spacing
Device supports TX status socket option.
Device supports HT-IBSS.
Device supports SAE with AUTHENTICATE command
Device supports low priority scan.
Device supports scan flush.
Device supports AP scan.
Device supports per-vif TX power setting
P2P GO supports CT window setting
Driver supports a userspace MPM
Device supports active monitor (which will ACK incoming frames)
Driver/device bandwidth changes during BSS lifetime (AP/GO mode)

 
Nunca se llega a conectar. Que estoy haciendo mal?
Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: kid_goth en Marzo 04, 2016, 06:55:06 pm
Creo que eso ya es si la tarjeta de red permite crear el access point, no?

que alguien me corrija pero estoy casi seguro jeje
Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: howara en Marzo 05, 2016, 04:13:23 am
Creo que eso ya es si la tarjeta de red permite crear el access point, no?

que alguien me corrija pero estoy casi seguro jeje

Eso pone en la docu https://github.com/P0cL4bs/WiFi-Pumpkin/wiki/Installation
Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: Blest777 en Marzo 05, 2016, 05:19:51 pm
Mi ubuntu esta instalado en la PC, no estoy corriendo en VM.  :'(

No se si es que algo esta mal configurado. Fijate en la imagen del terminar, creo que hay errores... Nunca se conecta el Fake AP en mi celular, he intentado muchisimas veces:

(http://s22.postimg.org/3qb78rrm9/Screenshot_from_2016_03_05_16_09_41.png)
Título: Re:No puedo instalar 3viltwinattacker-v-0-6-4 (Ubuntu)
Publicado por: elidiodos en Marzo 08, 2016, 02:09:11 am
Hola, jajaja estamos en la misma situacion.
Solo por aclarar un mensaje anterio donde decian que a lo mejor una tarjeta WiFi no soporta. En mi tengo una antena USB. Una maquina virtual con el software. En modo nat le brindo  internet a la MV. y Coloco directamente la tarjeta. Puedo hacer muchas cosas. Auditar redes WEP/WPA.
Linset para hacer un ataque Evil Twin Attack. Incluso compartir una red (cabe mencionar que la distro es kali y no puedo cambiar los parametros en el hotspot con una clave WPA). Es decir con el Hotspot si puedo crear la red y el cliente se conecta y navega.

Sin embargo con este software. El cliente no logra contectarse. Sin duda es problema del DHCP. Ya intente hacer todo paso a paso con airbase y hostapd (tambien con easy-creds)y sin exito.
Asi que amigo, si solucionar esto, comparte la solucion y desde luego si logro yo esto antes, con gusto lo posteo.

Saludos.